PDA

View Full Version : Just a couple questions



Austin S.
02-27-2008, 09:09 PM
Gotta couple questions for everyone. First off I want to make it clear that all the gigas eggs never developed. humidity was kept perfect. The factor why they didnt make it could have been temperature. It was kept anywhere fro 74-78 deg. constantly. I believe this is too low for egg incubation. Thus, why they did not develope, most just turned black, some developed mold on them as well. I dirlled several dozen holes in the shoa box incubator (same settup Ryan (Talkenlate) and Brian S. use. Now the eggs just could have been bad from the start, or it could have been a problem when I pulled them too early, b/c I was uncertain when they were laid, the male could have been bad, etc. No one will really know when eggs go bad. But I would like to prevent this from happening again to the best of my ability. The chalcodes is digging like a crazed fool, as well as the parahybana, and the crawshayi has blocked herself in the burrow, I see nothing but silk. For you people who do breed and raise them in settups like this, how do you regulate temp.? I can't set me thermostat at 80-83 deg. all day, I cannot afford it as of right now. I'm working most of the day, so I'd be afraid to use space heaters and things of that nature b/c of a possible fire. What about heat pads? I've heard from some people they work well, and from some they do not. Would putting two on each side of the shoe box regulate the temp good enough for developement? What about my gravid T's as well. For the breeders, do you bump up the temps for the ONLY gravd T's? If so, how do you do it? Thanks guys, I really appreciate it.

sick4x4
02-27-2008, 09:50 PM
my advice is the automatic thermostat....its a leave it and forget it kinda thing...you set the heat for where you want it and its controlled automatically...if it gets to hot it shuts off, to cold it turns itself on. you can get them at many reptile shops..worry free mate that's my advice....

wayne